Интерфейс пользователя CANNY Lab

Материал из CANNY Wiki
Перейти к: навигация, поиск

Интерфейс пользователя CannyLab состоит из единственного окна - главного окна программы.

Главное окно[править]

Главное окно программы делится на несколько областей:

  • заголовок окна;
  • панель главного меню;
  • панели инструментов редактора;
  • панель функциональных блоков;
  • рабочая область;
  • строка состояния.

В зависимости от текущего режима работы редактора те или иные элементы меню и панелей CannyLab могут быть недоступны или скрыты.

4 4 1.png


Главное меню[править]

Меню «Файл» содержит команды для работы с файлами CannyLab.

4 4 1 1.png  
- создание нового файла функциональной диаграммы;
- открытие существующего файла функциональной диаграммы;
- сохранение текущего файла диаграммы;
- сохранение текущего файла диаграммы с новым именем;
- сохранение «снимка» диаграммы в графический файл формата png;
- просмотр свойств текущего файла;
- история недавно отрытых файлов (до 5 записей);
- выход из программы.


Меню «Правка» содержит команды управления внешним видом редактора.

4 4 1 2.png  
- отмена последнего действия, при создании/редактировании схемы;
- возврат последнего действия, при создании/редактировании схемы;
- вырезание выделенной части диаграммы в буфер;
- копирование в буфер выделенной части диаграммы;
- вставка содержащейся в буфере части диаграммы;
- удаление выделенной части диаграммы;
- полнотекстовый поиск - поиск элементов, содержащих указанный текст;
- поиск следующего элемента, соответствующего параметрам полнотекстового поиска;
- поиск предыдущего элемента, соответствующего параметрам полнотекстового поиска;
- поиск функционального блока по его порядковому номеру;
- выделение всей диаграммы.


Меню «Вид» содержит настройки отображения панели инструментов и представления панели функциональных блоков, а также элементы управления отображением рабочей области.

4 4 1 13.png  
- масштабирование и отображение в рабочем окне всех элементов пользовательской диаграммы;
- настройки панели инструментов;
- настройки отображения панели функциональных блоков.
4 4 1 3.png 4 4 1 4.png


Меню «Устройство» содержит команды для работы контроллером.

4 4 1 5.png  
- поиск и установление связи с контроллером подключенным через USB;
- действия с системным программным обеспечением контроллера;
- действия с пользовательской функциональной диаграммой контроллера;
- информация о подключенном контроллере;
- пункт зарезервирован для реализации в следующих версиях;
- завершить сеанс связи с контроллером;
4 4 1 6.png - загрузить системное программное обеспечение в контроллер;
- стереть системное программное обеспечение контроллера;
4 4 1 7.png - загрузить пользовательскую функциональную диаграмму в контроллер;
- стереть пользовательскую функциональную диаграмму из контроллера.


Меню «Симулятор» содержит команды управления режимом программной симуляции работы контроллера в среде CannyLab.

4 4 1 8.png  
- включение/выключение режима симуляции;
- включение/выключение удержания фокуса на активном функциональном блоке;
- включение/выключение режима приостановки при любом изменении в данных;
- запуск/приостановка/продолжение выполнения диаграммы;
- выполнение активного функционального блока;
- выполнение диаграммы до активного блока;
- остановка и сброс симулятора в начальное состояние;
- привязка масштаба времени симулятора к системному времени windows;
- установка формата для отображения значений в режиме симуляции;
4 4 1 9.png - установка десятичной системы счисления;
- установка шестнадцатеричной системы счисления;
- установка двоичной системы счисления;
- установка символьного отображения данных.


Меню «Сервис» содержит сервисные команды и настройки CannyLab.

4 4 1 10.png  
- упорядочивание номеров функциональных блоков на диаграмме;
- изменить границы рабочей области по содержимому диаграммы;
- создание файла автономной прошивки контроллера;
- запуск программы CAN-monitor;
- изменение параметров CannyLab;
- выбор языка интерфейса CannyLab.
4 4 1 12.png - установить английский язык;
- установить русский язык.


Примечание: Галочкой обозначен текущий установленный язык интерфейса CannyLab.


Меню «Справка» содержит ссылки на данное руководство и информацию о программе.

4 4 1 11.png  
- ознакомиться с файлом истории изменений программы CannyLab;
- открыть справочное руководство по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- открыть указанную главу справочного руководства по CannyLab;
- перейти на страницу онлайн-энциклопедии CANNY Wiki;
- проверить наличие обновлений CannyLab;
- получить информацию о текущей версии программы.

Панели инструментов[править]

Панели инструментов позволяют получить доступ к наиболее востребованным командам при работе с CannyLab.

4 4 2 1.png

Панель управления рабочим столом позволяет масштабировать изображение рабочей области и изменять его размеры в пикселях. Для быстрого изменения масштаба изображения вращайте колесо мыши удерживая в нажатом состоянии клавишу «Ctrl» клавиатуры.

4 4 2 2.png   4 4 2 2a.png

Рабочая область[править]

Рабочая область программы предназначена для отображения, редактирования и отладки функциональных диаграмм. Фоном рабочей области является координатная сетка, облегчающая позиционирование на ней элементов функциональной диаграммы. Для перемещения по диаграмме отображаемой в рабочей области используются вертикальная и горизонтальная полосы прокрутки, колесо мыши или клавиши управления курсором.

4 4 3 1.png


Строка состояния[править]

В строке состояния отображаются: для какого типа контроллера предназначена текущая функциональная диаграмма, наличие связи с контроллером, наличие в подключенном контроллере системного программного обеспечения и пользовательской диаграммы. Кроме того, в режиме симуляции в строке состояния отображаются сведения об использованных пользовательской диаграммой ресурсах контроллера.

4 4 4 1.png


Панель функциональных блоков[править]

Панель функциональных блоков содержит все доступные для использования при построении функциональных диаграмм типы блоков. Функциональные блоки в данной панели объединены в группы по назначению и, в зависимости от настроек отображения, могут быть представлены в виде значков или списка. Прокрутку панели функциональных блоков можно выполнить при помощи вертикальной полосы прокрутки или колеса мыши.

Два варианта отображения панели функциональных блоков:

4 4 5 1.png   4 4 5 2.png

Диалог поиска функционального блока по его порядковому номеру[править]

Доступ к диалогу поиска функционального блока по его порядковому номеру CannyLab можно получить, выбрав пункт «Правка» => «Найти блок...» главного меню программы.

4 4 6 1.png

Диалог полнотекстового поиска[править]

Доступ к диалогу поиска текста по указанному фрагменту в CannyLab можно получить, выбрав пункт «Правка» => «Найти...» главного меню программы или используя сочетание клавиш «Ctrl+F».

4 4 6 2.png

Продолжить поиск введенного ранее фрагмента текста в рабочей области диаграммы можно используя пункт меню «Правка» => «Найти следующее», или нажав функциональную клавишу «F3»; либо используя пункт меню «Правка» => «Найти предыдущее», или используя сочетание клавиш «Shift+F3».

Диалог настройки параметров[править]

Доступ к диалогу настройки параметров CannyLab можно получить, выбрав пункт «Сервис» => «Параметры» главного меню программы.

4 4 7 1.png

Проверка обновлений - Выбор периодичности проверки наличия новых версий программы
4 4 7 2.png
Цвет выделенного провода - Выбор цвета отображения выделенной соединительной линии
Ассоциация с файлами *.cfd - Связывает тип файлов функциональных диаграмм с текущим экземпляром CannyLab
Ширина диаграммы по умолчанию - Ширина области диаграммы при создании нового файла
Высота диаграммы по умолчанию - Высота области диаграммы при создании нового файла
Масштаб диаграммы по умолчанию - Масштаб отображения области диаграммы при создании нового файла
Автоматический подбор масштаба при открытии файла - Способ отображения диаграммы при открытии файла (при включенном подборе масштаба диаграмма, при открытии, будет, по возможности, полностью вписана в экран — отображена в соответствующем масштабе)
Порт для подключения устройства - Выбор COM-порта для подключения устройств, использующих для загрузки программного обеспечения интерфейс RS-232 (CANNY 5, CANNY 5 nano, CANNY 5.2, CANNY 5 duo, CANNY 5.2 duo)
4 4 7 3.png


Примечание: Для сохранения настроек может потребоваться запуск CannyLab от имени Администратора.

Список горячих клавиш[править]

F1 Открыть справочное руководство;
Ctrl+N Создать новый файл диаграммы;
Ctrl+O Открыть файл диаграммы;
Ctrl+S Сохранить файл диаграммы;
Ctrl+A Выделить все;
Ctrl+Z Отмена последнего действия при создании и редактировании диаграммы;
Ctrl+Y Возврат последнего отмененного действия при создании и редактировании диаграммы;
Del Удаление выделенных элементов диаграммы;
Esc Выход из режима редактирования сети;
Left, Up, Right, Down Сдвиг экрана отображения рабочей области влево, вверх, вправо, вниз;
PageUp, PageDown Сдвиг экрана отображения рабочей области на страницу вверх, вниз;
Ctrl + колесо мыши Быстрое изменение масштаба отображения рабочей области;
Alt + колесо мыши Горизонтальная прокрутка рабочей области редактора;
Shift + колесо мыши Ускоренная вертикальная прокрутка рабочей области редактора;
Нажатое колесо + движение мыши Перемещение поля диаграммы внутри рабочей области («перетаскивание»).
Двойное нажатие левой клавиши мыши В режиме редактирования: на соединительной линии (сети) - быстрый вызов диалога переименования сети; на регистре - быстрый вызов диалогового окна редактирования регистра; на константе - быстрый вызов последнего использованного типа диалогового окна редактирования константы (установка значения константы в ручную или использование именованных констант). В режиме симулятора: установка/снятие контрольной точки (на сети) или точки останова (на функциональном блоке).
Ctrl + Двойное нажатие левой клавиши мыши В режиме редактирования: на константе - быстрый вызов альтернативного типа диалогового окна редактирования константы. В режиме симулятора: на соединительной линии (сети) - быстрая принудительная установка значения "1" / быстрое снятие (освобождение) ранее установленного значения соединительной линии (сети).